Confusing microSD issue

Discussion in 'Switch - Console, Accessories & Hardware' started by GermanFriend, Feb 10, 2019.

  1. GermanFriend
    OP

    GermanFriend Newbie

    Newcomer
    1
    Feb 10, 2019
    Germany
    Hello guys, i need help.

    After successfully payloading my Switch, i cant get access to any of my SD cards. Let me show you the workflow:

    MY SETUP

    Nintendo Switch
    Serial: XAJ70014??????
    System-Update: 6.2.0
    IMG_20190210_171952. IMG_20190210_161628.

    microSD-Cards
    a) Lexar 16 GB - SDHC
    b) TOSHIBA 4 GB - SDHC
    c) SanDisk 128 GB - SDXC
    IMG_20190210_160720.

    Software
    payload: hekate_ctcaer_4.6
    SD-Files: KosmosV119
    RCM-Loader: TegraRcmGUI_v2.5_portable


    MY WORKFLOW

    1. Checking if the SD-cardslot is working and recognizes the SD-cards

    a) Lexar 16 GB - SDHC: recognized! also formating works!
    IMG_20190210_162745(1).


    b) TOSHIBA 4 GB - SDHC: recognized! also formating works!
    IMG_20190210_163158.


    c) SanDisk 128 GB - SDXC: NOT recognized! Asking for FW-Update to use microSDXC and exFAT.
    IMG_20190210_163350. IMG_20190210_163602.


    2. Preparing payload and SD-cards
    2.1 Formating every card with "SD Card Formatter" like this:
    IMG_20190210_163716.

    2.2 Copy "KosmosV119.zip" to the ROOT of the SD cards like this:
    IMG_20190210_172057.

    2.3 Insert Cards to the Nintendo Switch.

    2.4 Set Nintendo Switch into RCM-mode with a jig and pressing "Vol(+)" and "Power"

    2.5 Select payload "hekate_ctcaer_4.6.bin" with "TegraRcmGUI_v2.5_portable" (the payload was included the "KosmosV119.zip" and has been seperately saved to the Desktop of my PC)
    IMG_20190210_171810.

    2.6 The payload obviously starts on the Nintendo Switch

    MY PROBLEM

    Every process accessing to the SD cards fails.
    The "Lexar 16 GB - SDHC" and the "TOSHIBA 4 GB - SDHC" are showing this Error:

    "Failed to init SD card. Make sure that it is inserted. Or that SD reader is properly seated!"
    IMG_20190210_165259. IMG_20190210_165759.
    The "SanDisk 128 GB - SDXC" shows this Error:
    "(FatFS) Error: NOFAT Failed to mount SD card (FatFS Error 13). Make sure that a FAT partition exists.."
    IMG_20190210_172300.


    MY QUESTIONS
    Q1: I would guess, my SD-Slot is working cause the OFW will recognize 2/3 SD-cards, am i right?
    Q2: Seems there is a need for an FW-Update to use SDXC & exFAT, but 2/3 cards are SDHC and all of them are formated on FAT32. Could the SDXC&exFAT-update solve my problem?
    Q3: If the SDXC&exFAT-update can solve my problem, is there a solution without updating to 7.0.0
    Q4: Maby there is anything im doing wrong. Can you tell me what?
    Q5: If you need more informations for give me a solution, please tell me.


    Wish you a nice week an hopefully i coult tell you where my problem is. I just booted a CFW on my PSP ans on my Nintendo 3DS, so im not a completely noob but im absolutely not a pro. Id say, im an interested noob with a tiny bit of experience.

    Thank you guys
     
  2. DarthItachiX

    DarthItachiX Advanced Member

    Newcomer
    2
    Mar 10, 2016
    United States
    jorgesd likes this.
  3. GermanFriend
    OP

    GermanFriend Newbie

    Newcomer
    1
    Feb 10, 2019
    Germany
    Thank you, but i cant even start a Custom Firmware from the SD Card and i dont know why. So this is my problem.
     
  4. DarthItachiX

    DarthItachiX Advanced Member

    Newcomer
    2
    Mar 10, 2016
    United States
    Format your card with this program ... http://www.ridgecrop.demon.co.uk/index.htm?guiformat.htm ... Then put all the files from Kosmos zip and try to do a Backup of your nand first .. because if you are getting to print your data like on the pictures that means that you are booting on RCM is just something is wrong with your sd card or where the files are located.
     
  5. GermanFriend
    OP

    GermanFriend Newbie

    Newcomer
    1
    Feb 10, 2019
    Germany
    hey, thanks for triyng to help me. I tried to backup but the same message appears. Guess my SD-Slot is broken? But why does it work for the OFW?
     
  6. DarthItachiX

    DarthItachiX Advanced Member

    Newcomer
    2
    Mar 10, 2016
    United States
    The other thing you can try is to reset the switch to factory default and format the micro sd with the switch and then load the files from kosmos again and retry to do a backup. Also you might want to re download the files in case they are corrupted. Make sure that the switch folder inside the microsd has full privilege access. Keep in mind that you are going to lose all the saves if you do a factory reset.

    Sent from my ONEPLUS A6013 using Tapatalk
     
    Last edited by DarthItachiX, Feb 10, 2019
  7. GermanFriend
    OP

    GermanFriend Newbie

    Newcomer
    1
    Feb 10, 2019
    Germany
    Hey, now i did a factory reset and formated the SD card (Lexar 16 GB - SDHC) with the Nintendo Switch. Then i started in RCM, injected the payload successfully.
    Now i tried three operations:
    1. Tools -> Backup -> Backup eMMC BOOT0/1
    = "Failed to init SD card. Make sure that it is inserted. Or that SD reader is properly seated!"

    2. Console info -> Print fuse info (that works) -> Press POWER to dump them to SD Card
    = "Failed to init SD card. Make sure that it is inserted. Or that SD reader is properly seated!"

    3. Console info -> Print SD Card info
    = "Failed to init SD card. Make sure that it is inserted. Or that SD reader is properly seated!"

    The OFW is recognizing the Lexar 16 GB - SDHC, maby im doin something wrong?
     
  8. DarthItachiX

    DarthItachiX Advanced Member

    Newcomer
    2
    Mar 10, 2016
    United States
    It looks like you have issues with sd slot ... try to look inside and see if there is a pin lifted or something inside. Also when you start the process to dump information push the sd card with your finger and hold it pushed to see if anything changes.

    Sent from my ONEPLUS A6013 using Tapatalk
     
  9. RunFwrd

    RunFwrd Member

    Newcomer
    1
    May 14, 2017
    United States
    hi im having problems trying to transfer everything from my micro sd card to another larger micro sd.
    i currently have a 128 gb card with sysnand 7.0 emunand 6.2 with sx os 2.5.3 also my emunand is not a hidden partition, i just made it so the files on are on the sd card so they could be transferred easier.
    everytime i transfer over to the new 256 gb card im getting errors on windows saying files are corrupted. it seems to only be the Nintendo folder.
    what is going on?
     
  10. DarthItachiX

    DarthItachiX Advanced Member

    Newcomer
    2
    Mar 10, 2016
    United States
    Transfer every folder by itself and check which one is giving you the error. The Nintendo folder is created by the Switch and the folder might not have Write/Read permission. If thats the case you have to change the permissions on the folder.

    Sent from my ONEPLUS A6013 using Tapatalk
     
  11. RunFwrd

    RunFwrd Member

    Newcomer
    1
    May 14, 2017
    United States

    it most def is the Nintendo folder. I transferred everything over separate. i dont think the problem is a permissions problem as you stated because I have done this before on my last sd card, being that this is my 2nd time upgrading and everything worked fine.
    and all of the permissions on every folder were the same which was Read only and the other folders copied over just fine.
    when i try to copy the Nintendo folder over it states on Windows that it cant move some files because they are corrupt.
    my 128 gb that i am transferring from works fine inside and running on my switch and everything is working so I dont see why when I try to copy over stuff onto my new sd card it's saying that. especially since i didnt have this problem last time.
     
  12. nantalos

    nantalos Member

    Newcomer
    2
    Nov 1, 2018
    Germany
    There's your answer.
    If windows says some files got corrupted then either the sd card or your sd card reader is acting up. Test and repair the sd card, with the windows tool or even better something like h2testw. Sometimes the sd card is a fake or too old, other times the sd card is still usable after you repaired it.
     
    RunFwrd likes this.
  13. DarthItachiX

    DarthItachiX Advanced Member

    Newcomer
    2
    Mar 10, 2016
    United States
    Like nantalos says, you can use windows system to check for errors ... also if you update your sd thru kosmos it has a warning that there is a slightly chance of the sd card to get corrupted if in you are using exfat.

    Sent from my ONEPLUS A6013 using Tapatalk
     
    RunFwrd likes this.
  14. RunFwrd

    RunFwrd Member

    Newcomer
    1
    May 14, 2017
    United States
    thats why i love you guys here. i really do think my card is fake. ive wondered that since i got it. its a samsung 256 evo plus, i have another one that works flawless with my 3ds but this one is lighter in color and does not look legit and i got it for a good deal. well hopefully i can get this worked out. thanks you guys.
     
  15. DarthItachiX

    DarthItachiX Advanced Member

    Newcomer
    2
    Mar 10, 2016
    United States
    There are a few programs that can check if they are fake.

    Sent from my ONEPLUS A6013 using Tapatalk
     
  16. RunFwrd

    RunFwrd Member

    Newcomer
    1
    May 14, 2017
    United States

    free?
     
  17. DarthItachiX

    DarthItachiX Advanced Member

    Newcomer
    2
    Mar 10, 2016
    United States
    Yes, just google for sd card checker or something like that.

    Sent from my ONEPLUS A6013 using Tapatalk
     
  18. PyroGoat

    PyroGoat GBAtemp Regular

    Member
    2
    Feb 27, 2015
    United States
    Free tool:
    H2testw
    Use "write+verify"
     
  19. RunFwrd

    RunFwrd Member

    Newcomer
    1
    May 14, 2017
    United States
    yup its fake. geez...
     
Loading...
Verdad o Reto BluRay-Screeener | Adventure | Samsung Mall 2.1.7